博客恢复啦,fourteen-colors.php插件升级导致出错!(已解决)

前几天随手打开博客,发现1行错误提示,博客网站再也无其他内容显示。

第一反应吓一跳,然后愣一会,哦,想到了,应该是上周某天胖爷手贱,把fourteen-colors的插件升级了,可能是这个举动导致出错了。其实胖爷平时对升级很谨慎,没事一般不动,wp一直提示4.6发布了,胖爷这还好好的3.9呢。

问题很简单,就是升级后fourteen-colors.php文件181行出现的is_customize_preview函数未定义。is_customize_preview出现在fourteen_colors_print_output函数中,老版本里没有is_customize_preview,看了下影响并不大,简单粗暴就从备份里找来了老版本的fourteen_colors_print_output函数内容直接替换,再次刷新博客就恢复正常了。

还是得定期做好整站备份才行哦。还有就是别随便升级,哪怕是一个小插件,即使升级了,也要及时观察是否出现异常。

原创文章,转载请注明: 转载自顾威敏博客

本文链接地址: 博客恢复啦,fourteen-colors.php插件升级导致出错!(已解决)

发表评论

电子邮件地址不会被公开。 必填项已用*标注

您可以使用这些HTML标签和属性: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>